С любовью к вашему контенту

ЗАКАЗАТЬ ЭФФЕКТИВНЫЙ SEO-КОПИРАЙТИНГ ДЛЯ ВАШЕГО САЙТА



57% сайтов на WordPress станут менее защищёнными в декабре

В декабре этого года PHP 5.6 и 7.0 перестанут получать обновления безопасности. По данным WordPress, эти версии используются на 57,1% WP-сайтов. Соответственно, в скором времени эти ресурсы станут менее защищёнными.

Поскольку уязвимости перестанут закрываться, использование устаревших версий PHP грозит сайтам потерей трафика и проблемами с ранжированием. Помимо возможных хакерских атак, возможны также проблемы с работой отдельных плагинов и самой WordPress. Поэтому владельцам этих ресурсов рекомендуется как можно быстрее обновить PHP до последней версии.

Сроки прекращения поддержки

Для PHP 5.6 обновления безопасности перестанут выходить 31 декабря 2018 года. Поддержка PHP 7.0 будет прекращена ещё раньше – 3 декабря.

Как определить, какая версия PHP используется?

Самый простой способ – войти в панель управления вашего хостинга и найти ссылку на раздел, связанный с PHP. Также можно использовать специальные онлайн-инструменты и плагины. Например, WordPress phpinfo(). Узнав текущую версию PHP, плагин можно будет удалить.

Ещё один способ – связаться со службой поддержки хостинг-провайдера и попросить их определить, какую версию PHP использует ваш сайт, а также запросить инструкции по обновлению.

Как обновить PHP до последней версии

  1. Создайте резервную копию своего WordPress-сайта. Для этого можно использовать плагин UpDraftPlus.
  2. Проверьте совместимость плагинов. Убедитесь, что все ваши плагины были обновлены до последней версии.
    • Если плагин не обновлялся в течение длительного времени, зайдите на его страницу и проверьте, совместим ли он с последней версией PHP (7.2).
    • Если плагин несовместим, тогда замените его на другой популярный плагин с той же функциональностью. Использование несовместимых с PHP плагинов может повлечь за собой угрозы безопасности.
  3. Обновите PHP. Войдите в панель управления хостингом, найдите раздел, посвящённый PHP, и обновите PHP-версию своего сайта до последней. При возникновении трудностей, свяжитесь со службой поддержки хостинг-провайдера.

источник: http://sajt-kopirajtera.ru

error: Content is protected !!